"Cannot write common metadata" error after upgrading


#1

I have recently upgraded one of my UrBackup servers to 2.2.3 beta and have noticed quite a few client logs showing the error “Cannot write common metadata”.

I have tried upgrading the clients to 2.2.2 beta and this still keeps happening.

Server is x64 Ubuntu 17.04.

Clients are a mix of Windows Server 2012 R2, Server 2008 R2, 7 and Ubuntu 17.04. Same error on most of them (although oddly not all).

If anyone has any ideas on this it’d be greatly appeciated.


#2

A more full error message:

WARNING: Error reading current metadata
ERROR: Writing metadata to /urbackup/BrentryFS/170730-1947/.hashes/root/etc/fake-hwclock.data failed
ERROR: Error saving metadata. Metadata offset cannot be calculated at "/urbackup/BrentryFS/170730-1947/.hashes/root/etc/fake-hwclock.data"
ERROR: Fatal error during backup. Backup not completed
ERROR: FATAL: Backup failed because of disk problems (see previous messages)


#3

It’s probably a race condition in the parallel metadata writing. Those are hard to fix, but I might have found it. We’ll see with the next version I guess.

You could also try this patch: https://github.com/uroni/urbackup_backend/commit/10338f2e57b5bd50044c6d1764b77797ac9b7caa


#4

Hi @uroni,

I upgraded to the most recent beta and am still having masses of issues with backups reporting metadata issues, e.g.:

Metadata file and “/urbackup//170824-0816/C/Users//AppData/Local/Google/Chrome/User Data/Default/Service Worker/CacheStorage/eadf114e35641d8a14aa9648d8e1c01b4b3bb3f0/fd7bfc75-5b64-4a2f-aefc-308de8e72b18/5e312668763f5627_0” do not exist. Skipping applying metdata for this file.

Sometimes tens of thousand of these messages on a single incremental file backup.

I’ve also just noticed that there’s a typo where metdata should probably be metadata.

Any ideas why I am getting this and is there anything I can do to help work out what’s going on?


#5

Could you check if this issue reoccurs after a full file backup or if it is fixed and the error persists from the last version?


#6

Did it work after a full file backup?


#7

Apologies, I did start by kicking off a full backup to see if it worked but then other stuff came up so I never checked it again.

I’m still seeing issues, but I don’t know if the full backup actually completed (or which of my hosts I ran it against).

I’ll start some more full backups and see where I get to and hopefully get back to you this time.


#8

Hi, I’m still using stable 2.1.19, and have the same issue. I have pretty large backup 1.7TB, and it made a full backup OK. Then it was this problem with metadata writing and incremental failed on the same file again and again.
I deleted the backup and did full backup again. After it finished OK it tried to make another incremental backup but failed on some other file but in the same way (error writing metadata to file in .hashes dir).


closed #9

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.