Cannot mount/browse vhdz image files on linux server

I cannot mount or browse my image files that are backed up on the linux server using urbackup server 1.4.5 from the ubuntu trusty ppa

I have tried to mount several image files but they give the same error.

start_urbackup_server --mountvhd /media/BACKUP/urbackup/t420s-1/Image_C_141212-0242.vhdz --mountpoint /media/image
Using temporary mountpoint /tmp/tmp.1En9UsxesB
Starting VHD background process…
Starting mounting…
mount: you didn’t specify a filesystem type for /tmp/tmp.1En9UsxesB/volume
I will try all types mentioned in /etc/filesystems or /proc/filesystems
Trying ext3
mount: special device /tmp/tmp.1En9UsxesB/volume does not exist

I checked and the folder /tmp/tmp.1En9UsxesB/ does get created but sure enough there is no volume in there

Thanks in advance

In /tmp/tmp.1En9UsxesB there should be only one file representing the raw volume? Is it there, or is it indeed empty?

EDIT: Okay. Can reproduce it. Thanks.

Okay, I was specifying a relative path for mountvhd. I need to fix it such that it supports that…

Can you run

/usr/sbin/urbackup_srv --plugin /usr/lib/ --plugin /usr/lib/ --mount /media/BACKUP/urbackup/t420s-1/Image_C_141212-0242.vhdz --mountpoint /tmp/tmp.1En9UsxesB --loglevel debug

And copy/past the output?

/usr/sbin/urbackup_srv --plugin /usr/lib/ --plugin /usr/lib/ --mount /media/BACKUP/urbackup/t420s-1/Image_C_141212-0242.vhdz --mountpoint /tmp/tmp.1En9UsxesB --loglevel debug
2014-12-14 23:09:14: Loaded -fsimageplugin- plugin
2014-12-14 23:09:14: Mounting VHD via fuse…
2014-12-14 23:09:14: VHD-Parent: “/media/BACKUP/urbackup/t420s-1/Image_C_141205-0237.vhdz”
2014-12-14 23:09:14: Volume offset is 524288 bytes. Configure via --offset
fuse: device not found, try ‘modprobe fuse’ first
2014-12-14 23:09:14: ERROR: Error mounting fuse filesystem

hmmm maybe now would be a good time to mention that this is an OpenVZ container and the host OS (Proxmox) is running ZFS for linux as storage for urbackup being mounted onto the urbackup container like this at startup

mount --bind /tank/backups/urbackup /var/lib/vz/root/105/media/BACKUP/urbackup

Can you try running modprobe fuse beforehand? (I’ll add it to start_urbackup_server if this is the cause of the problem)

I ran modprobe fuse without any error on the host OS (Proxmox) and added it to /etc/modules but i dont think that really has any effect on the containers and i get the error below inside the container, i think there is a way to add modules to the containers by edting /vi /etc/vz/vz.conf or something but it gets a bit confusing and sometimes requires reboots etc

modprobe fuse
modprobe: ERROR: …/libkmod/libkmod.c:556 kmod_search_moddep() could not open moddep file ‘/lib/modules/2.6.32-34-pve/modules.dep.bin’

there is some info here and i fooled with things for a bit but cannot seem to get things to work

Ok i have made a bit of progress i have gotten the

ERROR: Error mounting fuse filesystem

to go away by … and i am posting this here to help anyone who may find this helpful for OpenVZ
make sure your host has fuse in the kernel i added fuse to /etc/modules just in case
then also on the Host OS run this command

vzctl set VMID --devnodes fuse:rw --save

So now when i run /usr/sbin/urbackup_srv --plugin /usr/lib/ --plugin /usr/lib/ --mount /media/BACKUP/urbackup/t420s-1/Image_C_141212-0242.vhdz --mountpoint /tmp/t420s-1 --loglevel debug
2014-12-15 22:53:02: Loaded -fsimageplugin- plugin
2014-12-15 22:53:02: Mounting VHD via fuse…
2014-12-15 22:53:02: VHD-Parent: “/media/BACKUP/urbackup/t420s-1/Image_C_141205-0237.vhdz”
2014-12-15 22:53:02: Volume offset is 524288 bytes. Configure via --offset

I get a volume created in /tmp/t420-1 as below but i am still lost as to how to browse my files

/tmp/t420s-1# ls -lh
total 0
-r–r--r-- 1 root root 132G Jan 1 1970 volume

Well, now you’ll have to do the original invokation :wink:

Haha i already tried that getting this error now

root@urbackup-14-1:/# start_urbackup_server --mountvhd /media/BACKUP/urbackup/t420s-1/Image_C_141212-0242.vhdz --mountpoint /media/image
Using temporary mountpoint /tmp/tmp.B7cPIFxanT
Starting VHD background process…
Starting mounting…
mount: enabling autoclear loopdev flag
mount: Could not find any loop device. Maybe this kernel does not know
about the loop device? (If so, recompile or `modprobe loop’.)

I think there might be another problem with loop devices and OpenVZ:

The “volume” file is mapped to a loopdevice via mount, I think.

Excuse my ignorance, but it is a no go for OpenVZ then … as KVM and ZFS is a bit of a mess too.