Cannot find folder for particular clients data


#1

Hi All,

I just looked in the backup files for the data belonging to a client that is backing up just fine.
I can see and even open the files from the web interface but the client has no folder of it’s own in the urbackup file structure.

The client has almost 700GB of data backed up.
How is this possible?


#2

Odd, Can you take a screenshot of the file structure?
And show what you used as backup storage path and what s the client name?


#3

The authentication error is because the client is suffering from a drive failure. Hence the need to pull files from the server.
I need to pay them a visit tomorrow and have the data with me.
I am currently downloading from the web interface but not sure it’ll work as it’s a huge ZIP file. I am using latest beta server so hopefully it will be ok.

Server is running in a FreeNAS Jail and the path is mapped to a folder in the ZFS Pool.

Thanks

Update: The ZIP file is 27GB and fails to open / extract. I’m using an Ubuntu PC to open it.


#4

Could be some kind of symbolic link following problem if it works on the web interface. Maybe you could browse into it on the console and look at it with ls -lh. If you are accessing it via samba try looking at it with the samba user in the jail samba runs in.


#5

I’ve tried finding it via SSH and the root user. Everything else is there but not the client I need.
I can’t restore via the web interface. I have tried it on a new client (in a VM) it looks like it’s going to work but then does nothing. I can select individual files and they open perfectly.

Found it!!

Now where did the ? come from?

A big thank you to Uroni and Orogor for the help!


#6

If it says anything about why the ZIP download failed, that would be helpful perhaps wrt to fixing that.


#7

The reason the ZIP download didn’t work is because it was only 27GB.
I tried again this evening and the resulting 51GB ZIP opened perfectly.

I’m impressed!


#8

What was different so that it worked afterward?
Did you found out why the folder was starting with a ‘?’ ?


#9

I’m not sure why the original download was truncated. It was surprisingly slow to download 51GB over Gigabit Ethernet. Maybe an hour in total. SMB would have been transferred in seconds. So maybe it was just interrupted.

The folder starting ? is very odd. It is still functional and now backing up the repaired remote client.
Can I query the database and find the path from there? Maybe that will give me a clue.

Update: I just had to remotely reinstall the client as it was showing authentication failure on the server status page.
I copied the computer name field from the client and pasted it into a hex editor.


It’s just spaces at the beggining…

I have created a new client and it’s now backing up fine to a visible folder with no odd characters.

Thanks again for the help.