"Cannot access path to backup" Error

I had to reinstall Urbackup server on Windows 10 following getting a really nasty virus. I removed the server and client programs and obliterated all folders as part of the rebuild/cleanup activities. The client machine was rebuilt completely.

I am using Urbackup 2.0.32 and just trying to back up one client - a Windows Server 2012 R2. This server is running Hyper-V and there are a couple of VMs on it. It was not running Hyper-V when Urbackup was working correctly previously but I am backing up data files not accessed by the VMs which are located on a different drive.

The error I am getting is similar to one listed in other problems with three lines reported in the logs of both client and server: I presume these are related to the client rather than the server.

: ERROR: Cannot access path to backup: “\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy5\Backed Up Stuff” Errorcode: 2 - The system cannot find the file specified.
Constructing of filelist of “clientname” failed: error - index error
Backup had an early error. Deleting partial backup

I noticed that repeating attempts to do a full file backup results in the message changing slightly with the number of HarddiskVolumeShadowCopyNN increasing by one each time suggesting this is something to do with shadowcopy…

I have looked for advice in similar threads which suggest setting loglevel to “debug” but I am unable to save the args.txt file on the server for some reason - even with the Urbackup service stopped so can’t get further information. Changing the loglevel on the client didn’t change the error messages recorded.

The server backup path set G:\UrBackup and Urbackup has created folders in this location - clients, urbackup_tmp_files and one for the single client.

Backup for the client can be started from the server or the client but result in the same three error messages which appear in both the client and server logs. Starting a full file backup leads to construction of filelist but this fails per the error messages.

I have run vssadmin list writers on both client and server and find no errors on either.

Any advice would be appreciated as I cannot do backups until this is resolved.

Since posting this I have installed URbackup client on a Windows 10 VM running on the Windows Server 2012 R2 server that is having this problem and it works fine so the issue seems to be related just to the client running on the host OS. Is there a known issue with the client running on a Windows Server 2012 R2 system which is using Hyper-V?

Have you tried running any of the batch files on the UrBackup Server?

Namely, the cleanup_database, remove_unknown and repair_database batch scripts?

It sounds like you are running in to issues with incompatibilities that have arose due to the reinstallation and the client and server database being out of sync. That is a bit of a WAG though. Chances are that could have been resolved via running the scripts mentioned in post #3.

You will need to run your text editor as an administrator in order to be able to save to “Program Files”. Find the shortcut for your text editor, right-click and “Run as Administrator”. That will allow you to save the file. Running it as a normal user will not.

Thanks for your suggestions. I have now resolved the problem - or it has solved itself magically maybe? I did not run any scripts on the Urbackup server.

I once again uninstalled Urbackup on the client system (the Windows Server 2012 R2 host), then checked all registry entries had gone - a few had not so I removed them manually to ensure everything was completely clean. I then installed the Urbackup client software again and this time it started OK and has gone on to complete a full file backup.

I am not entirely clear what the cause of this issue was and will keep a close eye on backups for a while but it appears to be OK.

It was likely not the registry entries. UrBackup does not store much in the registry. Windows programs store some files in temp directories that can persist for a while even after an uninstall. You need to either wait for Windows to clean them up for you (the surest way is with a reboot) or know where they are and do so yourself.

If you uninstalled and then reinstalled right away, it is likely that UrBackup used those temp files. You should always reboot on Windows between uninstall and reinstall. Waiting 5-10 minutes should do it also, but a reboot is quicker, more certain and a cleaner way to do it to make sure nothing is persisting in memory.

I am inclined to agree with you about the registry entries john3354 - if I recall correctly they were in a part of the registry connected with firewalls.

I had rebooted the server on the problematic Urbackup client after installing the code but maybe Windows hadn’t got around to one of the wonderful and myriad things it does in the background and we have no clue about other than disk activity. Anyway we got another successful backup so this is now a closed issue.

I think maybe anyone doing a re-install on Windows should reboot and wait 10 minutes before installing the client to be on the safe side. Should be unnecessary though!