Can I mount drive from urbackup to a another system that can read the images?

I have urbackup running in a docker (on OMV) and I only have recent incremental image backups. I had a trouble with my installation and tried to recover the last backup but windows failed to boot.The restore with the recovery drive works but I also tried 2 others but wasn’t able to boot windows. I also checked for error in the log but there are no error reported for the image backups.

I made the mistake to store files on my system drive and I didn’t do a file backup of those files. And of course, some files are important :(. Another mistake was to trust the backup and overwrite the system disk.

Is there a way to read the files, the backup and database are on a HDD (formatted in ext4)? I have access to another computer where I can mount the drive. Can I install URbackup on another computer and reuse the drive from OMV with this new Urbackup installation to check the images and restore a recent working version?

All help is appreciated since I tried different things but restoring and copying take a long time.

Host /srv/dev-disk-by-uuid-6520ab50-5f8d-4d2e-a65c-174eafc4fa00/BackupClientsBackupclients
is Container /backups

Host /srv/dev-disk-by-uuid-6520ab50-5f8d-4d2e-a65c-174eafc4fa00/BackupURDB is Container /var/urbackup

It unfortunately doesn’t work in docker, but with other setups one can see image contents in most cases directly in the web interface.

You can assemble the image into a mountable image or decompress them if necessary ( UrBackup - Server administration manual ). Afterwards they can be mounted e.g. on Windows ( UrBackup - Server administration manual ).

Can you check if your image backup contains a SYSVOL (and ESP if EFI boot) image? If that is missing that might be the reason it doesn’t boot. The restore is also relatively new so perhaps try the earlier one if the SYSVOL image is present https://hndl.urbackup.org/Restore/urbackup_restore_2.3.1.iso .

Using a Windows ISO + command line you can recreate/make Windows boot with a missing SYSVOL image.

If you have a client running that cannot be image restored with missing SYSVOL please run "C:\Program Files\UrBackup\sysvol_test.exe" and post the output. That way the issue can be fixed. Thanks!

In the list of the backup there are 3 files for each backup.

I will try a restore to another disk with the 2.3.1 version.
I made an Ubuntu system (I understand that Ubuntu can read the VHDZ-files)
While installing URbackup in Ubuntu I need to enter the location.
The folders are on device 8TB1 that I defined in the docker:

  • BackupClients is /var/urbackup
  • BackupURDB is /var/urbackup

What location do I choose and how do I enter the reference?