Buch of problems in simple scenario - can I trust urbackup

Urbackup is running for 2 month in a simple scenario with a Win 10 and a Mac client as well as a win2016 and Raspi OS server.

I encountered a couple of problems that let me consider to switch to another product, and would like to hear you optinion if it is worth trying to fix the problems, or restart with an alternative product.

  1. Win 10 client. The client hold only stubs, not full copies for most files on OneDrive. Urbackup throws thousands of erros for thes files, and I have been unable to exclude the directory with whatever wildcards like /OneDrive/.

  2. Restoring directories via GUI yields broken Zip files on GUI even with the most trivial data data (a small number of plain text files, no links etc.).

  3. Restoring directories with urbackupclientctl “Errorcode: 4”. Not only does it fail, it seems to have poor consideration of proper error messages.

  4. The GUI does not show the Backup-ID, and hides URLs in general, so it is hard to guess from there what it coulde be. (RESTless design:-)

While Urbackup seems to have a fundamentally good architecture, these implementation flaws let me doubt its reliability.

I’ve been running UrBackup on my home/office network and at a client network for over two months now.

Windows Server and Clients, running v2.4.13 and v2.4.11, respectively. There are multiple UrBackup servers (~8) handling from 4-6TB each. Right now, we’re only performing File backups, but I ran and tested Image backups for 3 or 4 weeks.

We’ve performed restores successfully on multiple servers, using only the GUI. Figuring out how to view the “synthetic full backup” was a little tricky, and involved me starting up a thread here, but once that was resolved, it has just worked.

Initial setup did take a little time, because it was a bit different in its operation, and there was some buggy behavior with configuration. I think it took us about 2 weeks to work through the initial configuration issues, and then subsequent configuration and deployment was pretty fast.

Are you setting the exemption criteria on the server side, or on the client side?

I haven’t tested the CLI tools as yet, so I have zero comment on them.

I am setting the exemptions on the server side.

Did you test restore fromthe GUI?

Try setting an exemption from the client, as there have been inconsistencies with setting it from the server in this version. (This is something that v2.5.x is supposed to streamline)

And yes, I have done restores successfully from the GUI – both on the client side and the server side.

thanks for the information.