Booting image backup vhds in Virtual PC or Hyper-V


#21

I am experiencing the same too. This only affects UEFI machines. Images taken off mbr volumes are able to assemble correctly.

I have tried this on both EFI Windows 2008R2 and Windows2012. Both yield the same errors.

I think this could be the same bug which was fixed for mbr images but is now happening on efi images.


#22

I’m having the same issue. I was just trying to recover to a VM, just to test and make sure everything was working correctly, and stumbled across the same problem. My win10 uefi pc backup won’t reassemble with the .bat file, giving the “NTFS magic wrong” error. My other win7 MBR PC reassembled and booted without any issues. I tried using VHD for the image instead of VHDZ and made a new full image backup, but the problem persists, so that pretty much leaves me with having to use something like macrium for images in my PC at least.
Odd thing (at least for me), the image can be mounted and accessed through the web without any errors.