Beta version 2.5.19 pls advise on correct install procedure

Hello, I need help with both the client and server beta 2.5.14/2.5.19
What is the best way to install? Currently I have a clean install of both the beta client and server. Previously I’ve tried an install over top of 2.4.11/2.4.13 client/server.

In either instance I was not able to get linux image backups to work. I do have dattobd installed, LVM snapshots and partclone. Ubuntu 20.04 with kernel rolled back to 5.4 in order to install dattobd.

During the install I am not prompted for the type of backup i.e. LVM vs dattobd.

thank you for your assistance, I’ve been working on this for 3 days! and ‘think’ I’ve searched everywhere possible for answers.

Hey, I imagine you’ve either figured it out or given up by now, but here’s how I got it to work:

Uninstall the old (2.4.X) version on both the server and client and reinstall. (I couldn’t get the update script to work)
For the server, uninstall with apt-get remove --purge urbackup-server and reinstall the server with the .deb package here: Index of /Server/2.5.20 beta
I’m working off arm64, so I downloaded the source code and compiled; I haven’t actually tried the .deb

For the clients, uninstall with uninstall_urbackupclient. Do not reinstall yet.

Then add the clients to the server. On the web gui, there should be an “Add new client” button. Add your clients with that. I used the “Add new Internet client/client behind NAT” option because all my servers are local. If the client was successfully connected, a page should show up telling you to run a script to install the client on the client machine and connect. This page should also have a “Default authentication key” you should take note of. Run the script on the sclient and choose dattobd as the snapshot option if you want full image backups. If it’s not an option, you haven’t installed dattobd properly and you should do that first and come back to this.

If this doesn’t work, ensure the client is installed on your client and run this:
urbackupclientctl set-settings
-k internet_mode_enabled -v true
-k internet_server -v “SERVER_IP”
-k internet_server_port -v “55414”
-k computername -v “CLIENT_HOSTNAME”
-k internet_authkey -v “AUTH_KEY” #Default authentication key

You should now be successfully connected. If you have file backup paths and dattobd configured properly on your clients, you should be able to run your backups.

1 Like

Awesome, thank you. I had given up!! I’ll try this and post back. Just another question I had, my clients’ file system are ext4, will this work for image backups?
thanks again.

Actually, I checked my backups today and it looks like they’ve been failing with a “Cannot retrieve master boot record (MBR) for the disk from the client.” error. :frowning: I’ve been messing around with a few things, and I’ve also found that I’m having issues modifying settings from the web gui with the 2.5.14 client, so I reverted back to 2.5.13 clients. I actually got the file backups working with the “Linux device mapper” option (dattobd wasn’t working at all), but I’ll update this thread if I can figure out the full image backups.

Could you have a look into the client (debug) log if you have this issue again?

I don’t think there were any relevant changes with this version. So it’s weird this helped.