Bare line feed characters


#1

Relaying through our 365 tenant. Mail settings are configured as per https://support.office.com/en-us/article/how-to-set-up-a-multifunction-device-or-application-to-send-email-using-office-365-69f58e99-c550-4274-ad18-c805d654b4c4 | Option 1.

"This error occurs when the email program or device used to create or send an email message adds bare line feed characters into the message. When bare line feed characters are included in a message, the SMTP protocol chunking feature is required to transmit the message between email servers. Chunking uses the SMTP protocol BDAT command, but the recipient’s email server doesn’t support the BDAT command.

To fix the issue, the sender should send the message using an email program or device that doesn’t add bare line feed characters to messages. Most modern email programs don’t add bare line feed characters."

How can I remove bare line feed characters from the email that UrBackup is sending so that my emails will get through to the recipient?

Thanks!


#2

Anyone have an idea how I can configure UrBackup as per below?

To fix the issue, the sender should send the message using an email program or device that doesn’t add bare line feed characters to messages. Most modern email programs don’t add bare line feed characters.


#3

Modify the email sending code?


#4

Yeah, apparently the format that uses “bare line feed characters” (whatever that is!) is older tech and at least one big player’s mailserver (Rackspace.com) is complaining about it. The NDR screenshot I included at the top was what 365 said Rackspace (the recipient mailserver) said.


#5

It seems you need to disable BareLinefeedRejectionEnabled via Set-ReceiveConnector on your Exchange server https://docs.microsoft.com/en-us/powershell/module/exchange/mail-flow/Set-ReceiveConnector?view=exchange-ps . This seems to be disabled per default for compatibility reasons. So I don’t know why it is enabled in your case.


#6

This may or may not help, but if you go to the logs tab, right at the bottom there’s a tiny link “edit report script”, you could try clicking there, going through the script and replacing every instance of \n with \r\n might help, if the emails don’t get any other line feeds added elsewhere \n is the “Linux\Unix” way of doing things, a simple line feed (LF), windows, and thus Office 365, expects a carriage return (CR) first, adding the \r supplies it.

Some details explaining here in the “What’s a bare line feed in email messages?” section .

If that does solve it, let us know as it may benefit others, and the devs might even make the change, after all the (CR) won’t break Unix systems, it’s Windows that’s fragile…