Bad symbols in os_version_string hang a Web UI in Internet Explorer (jscript error Invalid character). How i can fix it?


#1

I’ve had UrBackup 2.1.20 on server 2012 R2.
After i backup first client I find that IE no longer connects to the server UIhttp://localhost:55414/.
Press Login button and Web UI just look like:

no other actions work.

In google chrome work fine but i dont want to install chrome on server.


#2

you can try centos+nginx


#3

In your enviroment (centos+nginx) WEBUI work on windows PC in IE11?


#4

yes


#5

Do you use Firefox or chrome for normal access?


#6

Chrome on my PC work, but IE on server and client (server too) didn`t. Also same problem in my PC with IE11.


#7

Try debug in F12
In http://localhost:55414/js/jquery.chash-9f7c65c84c8e8c3e317945e8fd89899b.js

on call:

return a.JSON.parse(b+"");

have a error: Invalid character.

value b “{\n"admin”: true,\n"allow_add_client": true,\n"allow_extra_clients": true,\n"allow_modify_clients": true,\n"client_downloads": [{\n"id": 2,\n"name": “SEMSRV21”\n}\n],\n"curr_version_num": 2001000020,\n"curr_version_str": “2.1.20”,\n"extra_clients": [],\n"no_file_backups": false,\n"no_images": false,\n"remove_client": true,\n"server_identity": “S0r0xABnHEeDJqjkrkoO”,\n"status": [{\n"client_version_string": “2.1.17”,\n"delete_pending": “”,\n"file_ok": true,\n"groupname": “”,\n"id": 2,\n"image_ok": true,\n"ip": “10.5.0.40”,\n"last_filebackup_issues": 0,\n"lastbackup": 1518559309,\n"lastbackup_image": 1518431279,\n"lastseen": 1518590715,\n"name": “SEMSRV21”,\n"online": true,\n"os_simple": “windows”,\n"os_version_string": “Microsoft Windows Server 2012 R2 Standard (build 9600), 64-ࠧ\n"processes”: [],\n"status": 0\n}\n]\n}\n"

os_version_string": “Microsoft Windows Server 2012 R2 Standard (build 9600), 64-ࠧ\n"processes”

In chrome it look like:

Where does this value (os_version_string) come from?

Seems a codepage issue.


#8

I change value os_version_string
from Microsoft Windows Server 2012 R2 Standard (build 9600), 64-ࠧ�來��
to Microsoft Windows Server 2012 R2 Standard (build 9600), 64-bit

Table clients in database C:\Program Files\UrBackupServer\urbackup\backup_server.db

and it works!!!

But if i run any bat script from c:\Program Files\UrBackupServer\ or try to mount image backup
value came back. :confused:

How can i fix it?

Maybe i can change any value on client (where does he get from).


#9


#10

Do you see the difference? In IE11


#11

No. I test compability from 9 to edge in IE developer tools (F12). Same result.
Problem not in webui translation.
I think problem in bad symbol in os name in my environment (russian language installation).


I change this value in db and client work. Maybe i can change any value on server, but i don’t know from where client get it.


#12

I installed en-us lpk language pack on my windows server 2012 and now client os looks like:


this solve a problem.
Thanks.