Backup size: -1 bytes

Hi! I’m testing this software in a small company for a bunch (5) of windows workstations.

I’ve been using it for 2 weeks now but for the past 2 days, every file backup that is performed appears as if it was “-1 bytes” in size under the server UI->Backups and clicking on any computer name.

The files seem to get copied and I can restore single files (as far as i’ve tested).

I tried restarting the machine, but no luck. It’s Arch LINUX. WHat can I do?


I have the some issues on win7pro as UrB server.
That instance work more than 1 year, and about ~1 moths ago,
since that moment file backups shows me size -1 for most actual clients.
Copyes is not empty, I see it normal.
I have to delete all copyes after that moment, but new copyes also have “size -1”
I try to fing what goes wrong in database - file “backups” -
filter and delete all records with “size_bytes=-1” and their dir-s, the same resuts.
defrag_database, repair_database, remove_unknown (for mass-deleted dirs)
and upgrade 2.2.11 to 2.3.7 - changes nothing.

I have 1 theory - one of users downloads jpg file from internet to besktop,
that file has very long name, over the win7NTFS limits.
Windows allow to dowload it, but can not rename or delete them, may be there is relations?
Something goes wrong in write\move\map\hardlink\etc that file and database relations?
I have to delete it from NTFS by… 7zip arch with delete )
“too long path” and etc errors

who knows, how to resolve the problem?

and one else sub-problem:
Key “delete” for last file copy become inacessible more then one of my instances (for all of their clients)

1 Like

Any news for this problem? i have the same situation in several pc

Our urbackup (2.4.15 running on ubuntu 22.04) started this one too 3 days ago (worked fine for years). Linux and Windows clients all have same backed up file size -1.

File backups
Backup time Incremental Size Archived? Actions
12/09/22 08:13 Yes -1 bytes ☐
09/09/22 08:16 Yes -1 bytes ☐
08/09/22 08:14 Yes -1 bytes ☐
07/09/22 08:12 Yes 839.04 MB ☐
06/09/22 08:10 Yes 176.4 MB ☐
05/09/22 08:08 No 863.13 MB ☐
02/09/22 08:17 Yes 838.93 MB ☐
01/09/22 08:15 Yes 838.98 MB ☐
31/08/22 08:13 Yes 838.97 MB ☐
30/08/22 08:10 Yes 176.52 MB ☐
29/08/22 08:05 Yes 839.36 MB ☐
26/08/22 08:57 Yes 838.92 MB ☐
25/08/22 08:55 Yes 176.89 MB ☐
24/08/22 08:53 Yes 838.48 MB ☐
23/08/22 08:51 Yes 838.9 MB ☐
22/08/22 08:49 Yes 839.27 MB ☐

Does clicking the “Recalculate Statistics” button in the admin UI fix it? I seem to remember this happening a few times to me and that maybe clicking that button fixed it.