Backup reporting as successful despite failing

I’m trying to keep backups of a file server, and UrBackup is reporting that backups are Ok and working as intended, but when I check the actual backups, the data volume hasn’t been successfully backed up in almost two weeks, and the logs for that client read:

Data on volume is too large for VHD files with 3.06327 TB. VHD files have a maximum size of 2040GB. Please use another image file format.

I tried switching image type to compressed VHD but still get the exact same error.

I’ve got a couple questions/concerns:

  1. Is there no way to perform image backups in this situation, or am I missing something? If not it’s no great loss, I would just prefer to keep image backups of everything for uniformity and to make recovery easier in the event that I have to restore the machine to bare metal.

  2. If I’ve got to switch to file backups for this machine, will the recovery boot disk still be able to restore from that backup? The primary reason I used image backups to begin with was that I was under the impression that the restore disk required image backups to function properly. The partition in question is not a boot volume, so is it possible to maybe do an image backup of the SYSVOL, ESP, and the boot drive, but do file-level for the storage disk?

  3. Further, it’s a little alarming that this error has been happening every night for the past 10 days and yet the status page happily reports that the server is properly backed up. Perhaps the logic on whether to indicate “Backup Ok” could stand to be re-tooled?