Backup of network drive stopped working

Hi, since 3 weeks I can’t backup my Z: drive anymore, having this error :

Cannot access path to backup: “Z:” Errorcode: 3 - Le chemin d’accès spécifié est introuvable.
Hint: Volume (“Z:”) does not exist. It may currently be not present. If you are trying to backup a network location via mapped network drives please be aware that mapped network drives are per user and the UrBackup client runs as “LOCAL SYSTEM” user per default. See on how to backup network locations

I browsed the use_shares page and many others but can’t make it works again :frowning:
It stopped working suddently, I can’t understand why, so I tried many things, until trying useless ones (just in case…)

  • I activated the default win10 local admin instead of my usual user
  • I set the service to run with this admin account
  • I started UrBackupClient.exe as admin (just in case…)
  • a local file backup is still working properly
  • I dismount/remount my Z: via command line and GUI (net use Z: \\shared_folder /user:administrateur mypassword /persistent:yes)
  • I tried using another driver letter …
  • I uninstalled/reinstalled urbackup client
  • I updated server to 2.4.13 and client to 2.4.11
  • I tried using UNC \\shared_folder (should this works?) but got this error :

Hint: Directory to backup ("\\shared_folder") does not exist. It may have been deleted or renamed. Set the “optional” directory flag if you do not want backups to fail if directories are missing.

  • I tried creating a link (should this works?) mklink /d \shared_folder \\shared_folder but got this error :

Cannot access path to backup: “\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy12\shared_folder\subfolder” Errorcode: 1326 - Le nom d’utilisateur ou le mot de passe est incorrect.
Hint: Directory to backup (“C:\shared_folder\subfolder”) does not exist. It may have been deleted or renamed. Set the “optional” directory flag if you do not want backups to fail if directories are missing.

Does anyone have an idea ?
Thanks in advance.
BR, vg

Did you have UAC disabled then enable it?

Silly question, but what happens when you try to access it normally?
If you login as the user urbackup is running as, can you access it, have you set such access up?
Mapped drives are great for human users, but UNC paths work better for backup, you can make mapped drives work, but it often involves either a registry edit, or disabling UAC either of which have security implications, but by default a program running with elevated privileges can’t access mapped drives.

The registry entry you’d edit would be:
Where you’d create a DWORD named EnableLinkedConnections and set the value to 1

That shouldn’t be needed using a UNC path.
My recommendation would be to logon as the user you have urbackup set to run as since changing from SYSTEM & troubleshoot accessing that share by UNC path as them… does the share have permissions for them to access it?

Thanks a lot Bearded_Blunder for your help.
I missed this point, but yes, I can properly access to Z: drive. I created a dedicated user ‘urbackup’ on the NAS (where data I want to backup are stored) and mount the drive on windows using “net use Z: \\shared_folder /user:urbackup mypassword /persistent:yes”. On windows I create a new user urbackup-client which is part of admin group, and from services.msc I run “urbackup client service for backups” as the user urbackup-client.

The key EnableLinkedConnections already exist in the registry and is set to 1.

Also, following your answer, I downgraded UAC to the minimum and restart the computer, but still the same result :frowning:

As the backup stopped working on january 14th and there was 2 windows updates kb4598242 kb4586876, I tried few days ago to uninstall it but still unsuccessfully.

I would like to try using UNC path but that failed too while trying to backup \\shared_folder. Do you think that creating a windows session/password identical to the unix user could help ?

I’m still interested if you have any clue.
Thanks again.

These don’t match, I’m betting you have a permissions issue for access as a result.

Thanks, so I go back to my previous setup :

  • windows ‘admin’ user (in admin group)
  • unix ‘admin’ user with full access
    Both have the same name and password, so I can access to my Z: drive without other credentials. I mounted it using “net use Z: \\shared_folder /persistent:yes”. Drive is properly mounted after a reboot and I have access to files and directories.
    But it fails with the same :frowning:

    Do you know how I can investigate permission issue ? I do not understand why urbackup service can’t access the network drive.
    My next idea is to set a linux machine…

Well I’d start by right clicking the shared drive, choosing properties, going to the security tab & seeing exactly who has what permissions.

If you start asking me how to fix things at the Linux end there’s a fair chance you’ll have to wait for someone else, I’m an all Windows setup, it’s been a couple of years since I had any Linux machines set up here, they’re rather finnicky about how things are set up with regards to file sharing with Windows though in that old experience.

After trying with another PC which was failing too, I tried with a linux machine and confirm smb and share settings were fine. I finally use the SysinternalsSuite to mount the network drive for the ‘local system’ account. This is the only workaround I found. Backup is running properly since many days now.
Thanks for you help.
BR, vg

1 Like