Add a Path with wildcards

Installed client on Windows system. When I go to the agent and choose “add/remove backup path” I can then add additional paths. The issue is, there is no support it seems for subfolder or wildcards.
I add say c:\games the system only backups files in the games folder. It won’t backup any subfolders and the files in those.
How do I add a path c:\games* as there doesn’t seem to be an option on the client to add subfolders or a wildcard, etc.?


Add the path without using wildcard, simply C:\directory1|dir1;D:\directory2|dir2 etc in the settings menu on the server web gui (make sure you use the dropdown to choose correct client or the settings will be server wide)

I did notice weird behaviour when using wildcards aswell.
F.ex if I want to remove the “System Volume Information” directory in windows I try to add as the documentation says: *\System Volume Information\* in excluded files it does NOT exclude it, at all.
Neither does *\System Volume Information
But if I add *:\System Volume Information it excludes it on all drives.
There is def something fishy going on with the wildcard selections on some cases.

I went into the settings on the server for the client and that is what was listed, for instance:
d:\datastaorage|Data but it would only backup files in that one folder.
If I changed it to:
d:\datastorage*|Data then it worked, backed up all files, and all sub folders and their files. But it is a pain to edit each individual setting on the server, easy to make a mistake. From the server should be a default or an option to recursively backup files and folders…

Make sure you are not getting hung up between the interaction of client specified backup paths and server specified backup paths.

If you add, change or remove a backup path on the client, then forevermore the client will ignore any backup path specification that you make on the server.

See section 8.3.4 in the urbackup documentation: UrBackup - Server administration manual

Those locations are only the default locations. Even if you check “Separate settings for this client” and disable “Allow client to change settings”, once the client modified the paths, changes in this field are not used by the client any more.

You mentioned:

This implies you made a change on the client.

So when you later say:

It no longer matters what you change this too, since the client will ignore it.

At least that’s what the documentation says.

Yep, and it doesn’t work that way.

Adding via the client, there is no way to add a wildcard option.

On the server, I modified the entry to include a wildcard “*”. That worked.

I was then able to make changes both on server and client… and backups run…
Just no way to add a variable via the client side, yep I can pick the base directory, then go to server, edit it, and then it works fine.