Active Directory problems


#1

Running UrBackup 2.1.19
Im trying to set up a connection to AD, with Win 2008R2.
No matter what settings combination, as soon as I try to test with an username/password (inside the settings screen for AD), I get:
Test login failed. Error: Unsupported protocol(ec=1), Protocol "ldap" not supported or disabled in libcurl

Not sure what Im doing wrong.
Not sure also if I can expect to enumerate users, or something.
Anybody out there using Active Directory that could give me a hand?


#2

What’s the UrBackup server operating system?


#3

Freenas 9.10 , urbackup is running inside a jail


#4

Ok, seems the FreeBSD base OS libcurl isn’t build with ldap support. Maybe the ports one is? Try installing/building that.


#5

I will try in 2 hours and will report back


#6

I installed the latest Curl, via pkg install , the one that was before was:
curl 7.48.0 (amd64-portbld-freebsd10.1) libcurl/7.48.0 OpenSSL/1.0.1s zlib/1.2.8

after pkg install now I have:
curl 7.53.1 (amd64-portbld-freebsd10.3) libcurl/7.53.1 OpenSSL/1.0.1s zlib/1.2.8 nghttp2/1.21.0

rebooted the jail.
Same error.


#7

Looks like it is compiled with LDAP=off per default: https://www.freshports.org/ftp/curl


#8

:slight_smile: looks like.
How do you turn this ON? do I have to compile again?
Not sure how, I guess I need some reading.
thanks for helping out.


#9

This is what I did, I downloaded Curl from source, compile with
./configure --enable-ldap
and got an error about not finding ldap libraries, ldap not enabled.
The I installed openldap-client via pkg-install and did this:
cp /usr/local/lib/ldap /usr/lib
cp /usr/local/lib/lber /usr/lib
cp /usr/local/include/ldap /usr/include
cp /usr/local/include/lber /usr/include

and then a make.

After that I did
./configure --enable-ldap
and got:
curl version: 7.53.1
Host setup: x86_64-unknown-freebsd10.3
Install prefix: /usr/local
Compiler: cc
SSL support: enabled (OpenSSL)
SSH support: no (–with-libssh2)
zlib support: enabled
GSS-API support: no (–with-gssapi)
TLS-SRP support: enabled
resolver: default (–enable-ares / --enable-threaded-resolver)
IPv6 support: enabled
Unix sockets support: enabled
IDN support: no (–with-{libidn2,winidn})
Build libcurl: Shared=yes, Static=yes
Built-in manual: enabled
–libcurl option: enabled (–disable-libcurl-option)
Verbose errors: enabled (–disable-verbose)
SSPI support: no (–enable-sspi)
ca cert bundle: /usr/local/share/certs/ca-root-nss.crt
ca cert path: no
ca fallback: no
LDAP support: enabled (OpenLDAP)
LDAPS support: enabled
RTSP support: enabled
RTMP support: no (–with-librtmp)
metalink support: no (–with-libmetalink)
PSL support: no (libpsl not found)
HTTP2 support: disabled (–with-nghttp2)
Protocols: DICT FILE FTP FTPS GOPHER HTTP HTTPS IMAP IMAPS LDAP LDAPS POP3 POP3S RTSP SMB SMBS SMTP SMTPS TELNET TFTP

then I rebooted the jail, and got the same error :slight_smile:Test login failed. Error: Unsupported protocol(ec=1), Protocol “ldap” not supported or disabled in libcurl

then I did reinstalled urbackup. just incase, but got the same error.
Im doing something wrong, I know, but I cant see where.


#10

Ops… forgot the
make and make install

but still doesnt work, now I get:
Test login failed. Error: Login denied(ec=67), LDAP remote: bind failed Success 80090308: LdapErr: DSID-0C0903A8, comment: AcceptSecurityContext error, data 52e, v1db1

i get the same if I try curl from the command line, to the domain.
Something on curl or on my windows domain, definitely not on UrBackup


#11

Hi Manuel, did you find a solution?

I installed via de ubuntu repository but I got also this error message no matter what I do.

Test login failed. Error: Login denied(ec=67), LDAP remote: bind failed Success 80090308: LdapErr: DSID-0C090400, comment: AcceptSecurityContext error, data 52e, v1db1