2 internet servers one internet name


#1

The original server is planned on having home users and testing seems okay for now. Since it appears I can’t specify alternate drives I’ve setup a secondary server to handle a specific machine with it’s own 10TB backup drive. The client machine is Windows Server 2012 R2 and the status is shown as “Connected to Internet server” but I can’t get the backup to run. I installed the client on another WS 2012 R2 server and got the exact same results. Is my port forwarding wrong? Server settings wrong?

This is for File backup only, no images.
Capture1
Capture2


#2

Well, I can’t understand why you’ve configured the second server to 55417 & then forwarded it’s traffic to 55414, make more sense to forward it to the port you set it to use.


#3

55414 is the default user interface, not changeable from within the program (though I’ve read there’s a way to get around it). The port forwarding works fine for seeing the server from externally. The server shows it sees the clients.

Is there something special about Server 2012 R2?


#4

Well I can’t see I’ve noticed anything special about Server 2012 R2, but then I’m only running the one server under it. I’m backing up several 2012 R2 clients with no (network) problems.

You could maybe try firing up something like Sysinternals TCP view to get a better idea of what’s actually happening, or possibly even Wireshark or similar. Check the traffic you’ve forwarded is actually going where you’ve sent it.


#5

Hi

Urbackup client only connect to a single interent server at a time (i did open a feature request for this).
If you shut down one server, the client will connect to the other internet server.

Also for that to work in “Internet server name/IP:” , you need to specify the 2 srver


#6

BB - I setup one of the 2012R2 on my first Ur server and it’s working fine, so there must be an issue with the second Ur server or port forwarding. After the backup finishes I’ll change the ports around so the 2nd server has the defaults and continue testing.

orogor - I’m not trying to connect to two servers, just running two separate servers on the same domain for different clients (I’m concerned the one large server will take too much space). The best solution would be if Ur allowed different clients to be pointed to different backup locations.


#7

Capture1
Set port forwarding of default ports to the second server.


Changed settings to default ports. Removed all clients, ran cleanup. Downloaded new configured client, clean install. The client sees the server, settings should allow backing up, but it just sits at “Connected”.
Capture2

I’m running the second Ur server on VMWare Workstation. Maybe this is the issue.


#8

You could play with making the storage for this client “BIG_BACKUPS” a symlink to some other storage, no idea how well that would work though…

You might be able to do something with Storage Spaces, or creative choice of where you mount another hard drive in the file-system (in a folder rather than assigning a letter), maybe you can arrange that client’s backups to land there… I had concerns about Ur’s deduplication in that scenario, which may have been unfounded.

I personally solved having a client that creates massive backups by using a huge expandable DAS box (Drobo) my backup storage, NAS should work too… enough expandable capacity for whatever Ur wants to use even with one of the clients using lots.

I’m not convinced VMWare has anything to do with it per-se, my server and a number of the clients are under a VMWare variant too (ESXi), though with Workstation, you obviously introduce an extra bit of network config for the VM. How is it’s adapter set? NAT, Bridged,? If NAT (might be called shared or something, I’ve used so many virtualization solutions I mix up the terminology between vendors) you’ll need to do forwarding there too, I did that once myself for something or other years back. Bridged so the VM gets it’s own IP and looks like a whole separate machine to the network is generally simplest even if it’s not the default, unless you have a need to specify NAT or Host Only.


#9

Bridged, replicate state on or off no difference. I have a 4 port Intel adapter, one port dedicated to VM’s (only one other VM running). There’s no way to specify a single port for a single VM.

I have the 10TB drive, I’ll try mounting it as the name of the client in the backup folder. Will be something new to learn. I was hoping to stay away from running a second physical server (the main is plenty for such minimal requirements).


#10

Perfect, worked like a charm. Mounted the drive as the client name, client backed up to that folder without complaint.
Capture

Thank you BB!