2.2.11 cannot fully configure package. Ownership of /var/urbackup is read only. Solved

I need to correct the following error:
dpkg-reconfigure urbackup-server
/usr/sbin/dpkg-reconfigure: urbackup-server is broken or not fully installed

This forum seamingly has a reference to that issue, but it is too abstract for me.
By @uroni :
The btrfs subvolumes are set to read-only after a backup is finished. You’ll have to set them to ro false if you want to change them.

But really you should move the prophet to the mountain and set the urbackup group id to the one before (groupmod) ;). You’ll see the group id e.g. in the output of stat.

So when attempting to apt upgrade or even reinstall I get this:

Setting up urbackup-server (
chown: changing ownership of ‘/var/urbackup/mComputer/180421-1305_Image_SYSVOL’: Read-only file system
chown: changing ownership of ‘/var/urbackup/mComputer/180421-1305_Image_C/Image_C_180421-1305.raw’: Read-only file system
chown: changing ownership of ‘/var/urbackup/mComputer/180421-1305_Image_C/Image_C_180421-1305.raw.mbr’: Read-only file system

The system had a working installation of urbackup before.
So far I did the following:
#apt upgrade
#apt autoremove
#dpkg --remove --force-remove-reinstreq urbackup-server
#apt install urbackup-server

None of the above helped, though.
Here is the configuration:

cat /etc/urbackup/backupfolder

ls /var/urbackup/ -ld
drwxr-xr-x 1 urbackup urbackup 1640 Jun 16 13:26 /var/urbackup/

What else one can do?
Thanks for any answers

Perhaps this will help you?

btrfs property set -ts /path/to/snapshot ro false

Use at your own risk!, i’m no expert on btfs, nor have i tried the solution specified.

1 Like

Thank you @MWubbema for your input.
I marked all of the occurences of read only subvolumes as “ro false”.
The end effect was that ubuntu apt upgrade was able to finish its process with success.
btrfs prop set -ts /var/urbackup/mComputer/180224-1147_Image_SYSVOL/ ro false
btrfs prop set -ts /var/urbackup/mComputer/180224-1147_Image_C/ ro false

dpkg-reconfigure urbackup-server no longer spitting an error.
So I guess this has been fixed with your help.

Thank you.