100% CPU during Image Backups

Im running 2.1.19 server and testing 4 Windows clients with the latest CBT client software.
Server is running on a jail, inside FreeNAS 9.10.1-U4 which is basically FreeBSD 10.3-RC3

Everything runs fine, image backups , full size backups, incremental, etc
But I notice that my CPU goes to 100% with just two simultaneous images.
The temperature goes all the way to 95 degrees, if I keep doing this the CPU wont last long.

Granted, it is an i3-4360 with 16 GB of RAM but I dont think urbackup would need much more than that.
During full file backups, SMB transfers, Rsync to another server, maxing out file transfers via Samba from multiple machines, the CPU never go above 15%, so something might be going on with the image backups.

I dont know if there is any way to alleviate the issue.

When the server is receiving only 1 image, the CPU sits at 55%.
Iddle is under 5%
I saw a similar post from last year on an older version of urbackup, but the OP fixed it by changing the compression of the urbackup path to lz4, and thats what I originally have on mine.

I can provide any log, screenshot, debug, etc, if needed,
Thanks guys !

Turn off compression and hashing in the Advanced Tab and try again.
These two consume a lot of CPU time out of their nature.

You could also check if the CPU load is caused by I/O Wait or actual calculation.
i dont know if FreeNas offers this out of the Box, Synology NAS’ do - Windows aswell.
As FeeBSD and Linux are relatives you could give “top” on the Terminal a try.

Had a I/O Problem as well in my Testing-Environment because the “Storage” was a single Disk that just died on the load - the Switch to productive (12 Disk Raid6) solved that.

Check if you enabled Temp-Folders.
If so, this shouldnt run on the Same Volume as you’d have at least doubled Read/Write on the Volume (first to temp, then to Destination).

Hope i could help. :slight_smile:

Ill try disabling compression. Not sure where to find “hashing”
I will check about the I?O wait.

No temp folders, I did a default install that has that turned OFF by default.

The hash options are located in “Settings -> Advanced”
Per default a few transfer modes are set to hash verfication maybe this has an impact.

Hi, @Nolan!
Thanks a lot, in my case Trunas server and Win10 client went from 100mbps to full 1gbps. Thanks!!! I let ZFS to take care about compression.