Wrong dependency in 2.4.9 Debian package

The Debian package v2.4.9 of urbackup-server can not be installed because it depends on libcrypto++9 which is not available on Debian Buster.

I’m unable to up- or downgrade the package as of now, this should definitely not happen and should be tested beforehand.

Okay, this package works on my Buster installation. But this package does not work.

I just installed Buster 6 days ago, along with the latest .deb for urbackup. I may have missed error messages. I’m having some issues with file backups, do you think it might be related to libcrypto?

edit: I just looked. I missed the latest. I grabbed urbackup-server_2.3.8_amd64.deb Are there any other nuances you’ve discovered?

Hmm, worked for me.

when I run dpkg -I urbackup-server_2.4.9_amd64.deb it shows:

Depends: debconf, sqlite3, libc6 (>= 2.28), libcrypto++6, libcurl4 (>= 7.16.2), libfuse2 (>= 2.6), libgcc1 (>= 1:3.0), libstdc++6 (>= 5.2), zlib1g (>= 1:1.1.4), debconf (>= 0.5) | debconf-2.0