Windows 7 total image backup restores only 23% results in BSOD

Ran urbackup image backup of my entire C drive. That took 866 minutes.

I then ran a restore using the restore iso and that took 175 minutes, at one point going from 23% to 100% in seconds and then asking to reboot. I thought that might make sense since the original drive was not 100% full.

Upon reboot, the system BSOD and went into a reboot loop.

I tried to restore two other times and all failed.

I removed the hard drive and put it in a USB 3 case and attached it to a different windows machine.

I then ran the restore and the same thing happened. During restore 23% goes to 100% in seconds, the resulting restore is a BSOD.

Just to make sure it was not a hard drive issue I ran the restore on a vm and had the same problem.

Fortunately the files seem to be intact on the restored image, but it will not boot.

Any advise?

Hi Eric,

Do you know which BSOD you get? Is it “Inaccessable boot device”? Going from 23% to 100% could be normal, if you C drive was only 23% full of data. That doesn’t have to be a problem.

It could be as simple as the system getting confused after restore how to boot your machine. Such as that after restore the disk and volume ID are different then what is written in your BCD. If you have a Windows install medium, or are able to boot to system recovery, you could run a command prompt and try to rebuild your BCD:

bootrec /rebuildbcd

Thanks for the suggestion MWubbema.

The BSOD comes up for like 1/2 second then goes right back into reboot.

Is there a way to stop or prevent immediate reboot after BSOD so I can see the error?

It’s a little tricky, usually you need to boot into Windows, open Advanced system settings -> Startup settings and uncheck the checkbox to reboot automatically if Windows crashes, but without being able to boot Windows, it’s a little hard to uncheck that checkbox.

Perhaps try something like recording a movie clip of your screen with your smartphone and pause the playback so you can read the BSOD?

Fortunately I had a backup using my standard Windows 2016, so I am past the problem. I was hoping this was a known issue and that perhaps others had some insight on.

I had hoped using Urbackup I could get rid Windows Server VM for backups. Looks like that’s not going to be the case, so I’m going to give up for now and perhaps come back to the program at a later date.