UrBackup Server and Client 1.4.9

Only for testing purposes

A few bug fixes and new advanced settings.


  • New server side advanced setting to not run the client with background priority
  • New server side advanced setting to not follow symlinks on Linux clients


  • Added Estonian and Turkish translation
  • Read ahead in separate thread to increase image backup performance


  • Fixed bug where garbage was appended to the end of a decompressed VHDZ file. This causes this file to become unmountable e.g. with the VHD mounting integrated in Windows
  • Added turkish translation.

Download at:




  • Fixed bugs in read ahead during imaging
  • New tool to write compressed/incremental volume images into one disk image with proper layout and master boot record. On Windows assemble_disk_image.bat on Linux start_urbackup_server --assemble "a.vhd;b.vhd" --assemble_output "disk.vhd"

Does the assembling of images only work for incremental images? Does it still work if the system has a system reserved partition?

Will the batch file work with 1.4.8? Or does it tie in to executables or libraries that are specific to 1.4.9?

You will need binaries from 1.4.9 for the bat file to work.

Okay tested this with full image backups on both Windows 2008 and Windows 2012. Assembly for the Windows 2012 image works perfectly but does not work for Windows 2008.

When I tried to run assemble batch file for Windows 2008 images, it says:

Error reading cluster code 529
Warning: Volume not an NTFS volume. Copying all blocks…
Error: Trying to write beyond partition (2)

Updated again to maybe fix that problem (untested).

It also fails to read the NTFS bitmap. If that image is small enough and contains no sensitive information I might be able to fix that if you send it to me.

After applying the fix, the error “Trying to write beyond partition (2)” is replaced by “Error reading from input VHD file”.

Did anyone manage to test and observe the same?

Fixed this and released 1.4.9 now.

Thank you for fixing this. Will you be posting the incremental code commits that leads to the final release of 1.4.9?

Just wondering if anyone has tried the new vhd assembly feature for Windows 2003 image backup.

It seems to work fine on Windows 2008 and above. After assembling the vhd for a Windows 2003 image backup, it seems that the contents are unreadable after I tried to manually mount the vhd. When mounted on Windows, it will ask to format the disk before i can use it. I also noticed that the filesystem for the mounted vhd shows up as RAW instead of the expect NTFS.

Any ideas?

Can you post the full log of the image assembling?

Here you go:

Sectorsize: 512
Clustersize: 4096
ClustersPerMFTNode Offset: 48
MFTStart: 338921
Attribute Type: 16 nonresident=0 length=96
Attribute Type: 48 nonresident=0 length=104
Attribute Type: 128 nonresident=1 length=80
Attribute Type: 16 nonresident=0 length=96
Attribute Type: 48 nonresident=0 length=104
Attribute Type: 128 nonresident=1 length=72
Writing E:\HOSTSVR23\Image_c_090215-1322.vhdz into output VHD…
Optimized by only writing used NTFS sectors…
Assembling… 0%


The above was the log in debug mode. The assembling reaches 100% without any errors.

Anyone else tested this out? The only difference for the assembly for Windows2003 images are that I only select the single image backup for C volume. Unlike Windows 2008 and above, I have to choose the sysvol and C volume images.

I believe you can find them by doing a compare on the repo.

this may be a dumb question but is there a way to go from 1.4.8 to 1.4.9 server without reinstall and having to reset all your clients and and backup jobs

Install the new server version without uninstalling the old version.

1 Like

I moved a post to a new topic: Windows 7 laptop goes to sleep during backup

Hi Uroni.
I have one question. There’s new client on your web page 1.4.10 but it’s not available on sourceforge web page (autoupdate or any other files). Is there some reason to this?