Urbackup server 2.2.11 - Debian buster libcurl3 superseded by libcurl4


#1

After a recent Debian updates Urbackup server 2.2.11 is not working with debian buster (testing).

Unfortunately many debian packages are relying on libcurl4 over libcurl3 causing me not to be able to use Urbackup server.

root@mimer:~> dpkg -l libcurl*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
=====================================================-====================
un libcurl3 (no description available)
ii libcurl3-gnutls:amd64 7.60.0-2 amd64 easy-to-use client-side URL transfer library (GnuTLS flavour)
ii libcurl4:amd64 7.60.0-2 amd64 easy-to-use client-side URL transfer library (OpenSSL flavour)
un libcurl4-gnutls-dev (no description available)
root@mimer:~> dpkg -l urbackup-server
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
++±=====================================================-====================
rc urbackup-server 2.2.11.2193-1 amd64 Server for backing up clients

Any suggestions on how to overcome this?

Edit: I can see others are affected by this as well just with other software:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=900511