There is a serious translation error in Chinese

Hello, there is a serious translation error in Chinese, version 2.2.7. How do I modify these wrong translations? The screenshot is as follows

@uroni

After I know urbackup thoroughly, I’d like to complete the translation and give it to the community

https://urbackup.atlassian.net/wiki/spaces/US/pages/884740/Translate+Web-UI

1 Like

thanks very much

@uroni @orogor
To solve this problem, I checked the JS file in my server. The translation error should be in frontend or webinterface file. But I checked the content of the file and did not find this translation content. Why?

Hello, how can I make the local client display in English? The operating system is Chinese, the default display is Chinese, I hope the client display for English, convenient debugging

Hi

At the bottom left of the ui

Hi,That’s the server language setting. I set it in English, but the client still displays the Chinese language.

你好,你是哪的?我青岛的。我也=刚刚重新校对了一遍

me too ,I changed lot of phrase in the language file and restarted the server,but nothing happend.

This is shown from the tray icon client. You’d have to edit the file in C:\Program Files\UrBackup\lang\zh_CN. (Convert with https://stackoverflow.com/questions/10863840/how-to-convert-gettext-mo-file-into-po-file , then edit in e.g. https://poedit.net/ , then convert back with msgfmt , or msgfmt the file from transifex)

what about the web UI?

You can edit translation.js or generate translation.js from the .po files. See https://github.com/uroni/urbackup_backend/blob/dev/urbackupserver/www/update_translation.bat (you’d need to install the tx tool from transifex).

Make sure to reload the web page such that it doesn’t use a cached translation.js. How this works depends on the browser. In Firefox it is CTRL+SHIFT + R.

Which is the translation.js file.I just found a similar one and changed some Chinese characters.Then cleared the cache of the bowser and reloaded ,but still nothing happened.
I tried many times……