The Disk you are trying to restore to is too small.. only 1KB are available


#1

I imaged a Windows Server 2008 R2 physical machine. I am restoring the images to a KVM virtual machine. The first (Drive C:) restores without error. The second fails before even starting, with the message: The disk you are trying to restore to is too small.The partition to be restored has size 781.167 GB, but with this disk only 1KB are available. The disk I’m restoring to is 832 GB in size. I’m confused as to why the restore client (2.1.1) is reporting this.

When going through the restore procedure, I select the Drive to restore (D:), and then select the disk to restore it to, which it reports as 832G: QEMU HARDDISK Size 832G (Yes/no). So the dialog boxes give evidence that it knows the drive is 832G, and presumably is bigger than the image I’m trying to restore.

The server is compiled from source code (2.3.7) onto an openSUSE Leap 15 linux platform. I have built one previous machine and it did not experience this when backing up another server at another site.

Please advise. Is there any debug information I can generate, and where can I obtain more information? Thanks!


#2

In my diagnostic research, I’ve determined that it has something to do with the image I generated; I was able to restore the C: image to the 832 GB partition without error. I originally imaged to two drives as a group via urbackup, and the image logs state that they completed successfully. I have removed the images several times via cleanup, and I’ve tried to image the D: drive by itself, always getting the same results. The source drive originally was 1.3TB in size, but using various defraggers, I was able to free up enough space to shrink the volume to +/- 799GB. This should put me where I need to be in terms of sizes on the source and on the target.

When I originally tried to restore the drive, it had reported that the source image was 1.3TB and that the destination was 832GB, and wouldn’t work; that was the trigger to shrink the volume, but since then, all I receive is the 1KB message stated in the title.


#3

I was also sure to restart the source server after cleaning up the volume, and I completely removed the client from urbackup, and ran the cleanup to purge out the db (at least I think that’s what the cleanup is doing after I remove the client).