Slow down backups?

Is there a way to “slow down” the backup process on the Server? UrBackup was working fine, but for some reason its maxing out the RAM now and killing the process with OOM:

20210328T093043: [91630.256815] Out of memory: Kill process 21612 (urbackupsrv) score 485 or sacrifice child
20210328T093043: [91630.258779] Killed process 21612 (urbackupsrv) total-vm:2450836kB, anon-rss:988632kB, file-rss:0kB, shmem-rss:0kB

This is what htop shows - and most of it is urbackup:

Any ideas? I’d hate to have to upgrade the backup server just cos its running out of RAM, as that doubles our server costs for it :frowning:



I’ve been having the same problem. Sometimes UrBackup uses so much memory that Linux itself starts running out. At which point Linux itself starts killing processes to free memory, killing UrBackup.

Limiting the number of simultanious backups seems to help a bit, as does adding more RAM to the system. But I haven’t been able to fix it compeltely yet. I’ve put a Nagios check on port 55414 and 55415 for now so I get warning when the process is killed.

Yeah I can see it happening. Doing a htop, I can see that % RAM usage for urbackupsrv was 30.5%, then a minute later, 30.6%, and it keeps going up. Currently at 32.9%, and only 40% through. Now 33.5% since I started writing this

I hope the backup gets to the end :confused:

62%, and up to 1.25gb out of 1.95gb :frowning: Not sure its going to run through even after killing off some other processes

Its weird, as it used to work fine. Does urbackup update itself at any point? Just wondering if something broke after an update? (it has been running fine on this server for 2-3 months)

Oh, and i’ve noticed that if UrBackup has less then 6 GB of RAM available, the problem tends to happen much more often. Mostly the server stays within a few 100 Mb’s of RAM. But when a backup is running, especially a full image backup (where is creates a incremental image backup and then consolidates the backup into a full backup on the UrBackup server) the RAM usage spikes.

Could be perfecly normal behavior though.

Playing with the max concurrent backups & “Total max backup speed speed for local backups” settings may help, if the server is doiong less at once I suspect it may reduce memory requirements.

Thanks. is that relevant to backups being pulled from another server though? (I’m copying backups from our “clients” onto the dedicated backup server)

I think (hope) it is going to run through this time. Its at 60% RAM being used (by urbackupsrv), but its at 91% completed - and has been stuck at 1.5gb RAM for a while.Just hope it doesn’t die at the last hurdle again