Restore CD not supporting Intel LAN controller on a Intel Z87 main board

I tried a restore today on a machine I have with a Gigabyte GA-Z87X-UD4H main board, which is a based on the Intel Z87 chipset which I got in 2013. Unfortunately the urbackup version 1.1 CD doesn’t manage to drive the LAN interface on that motherboard. I tried a clonezilla CD I had around which has a newer kernel and that worked fine with the LAN interface but doesn’t support urbackup, so it seems more recent Linux kernels work with that hardware.

Next step for me seems to be to try the 1.1.1 restore CD with more firmware and failing that build a Urbackup restore CD with a newer kernel, unless anyone has a better idea. I am curious how well urbackup will handle the GPT on the drive on that machine.

Yes, I’ll have to update that restore cd. It is based on debian live. It would help if you told me if it works with that or not:

GPT partitioning is currently not supported.

When do you plan to update the restore CD? I’m facing the same problem and the urbackup restore cd does not recognize my ethernet device (ifconfig shows only the lo).
I’ve tested the Debian Live 7.7.0 standard, and it worked just fine - so all ethernet interfaces are recognized.

Ethernet Controller: Intel Ehternet Connection I217-LM

I uploaded a fresh restore cd build here: Can you try this one?

If it does not work, it would be interesting which package the firmware for your ethernet controler is in. Perhaps you can see in dmesg which firmware it loads?

Great - the Ethernet Controller hast been found and a connection between client and server is now established!

Will now test, if restore procedure works properly…

Thank you! :wink: