Question about image restore

I’m running a few UrBackup servers for friends and family (x2 on Win10, & 1 UrBackup appliance CE). Having noticed that urbackup server takes some time to stitch together the synthetic full backup, I’m wondering if attempting an image restore before this process is complete could cause a failure.

So, does one need to wait for the dust to settle before attempting a restore?
If it can cause a failure, what would it look like?

I recently attempted a restore to a 1TB Samsung 860 EVO when the 1TB HDD started getting pretty slow to read & write. Source/target machine is an 8th gen Intel i7, network is GbE, client and server on same Gb switch. I ran an incremental image backup, and a half hour later tried to restore. I wound up aborting the restore after 2 hours “stuck” at 25% (it was late and I was at my cousin’s house on a work night). Today I’m going to bring the machine (and the urbackup server) to my house and try again, and thought I’d ask the community’s thoughts.

It doesn’t stich together anything during restore so this must have been caused by something else. There are log files in /root on the restore linux, if you are a bit Linux savy.