No paths to backup configured when linux client

I have installed 2.2.5 client on Ubuntu 16.04 by this command

TF=mktemp && wget “http://server_ip:55414/x?a=download_client&lang=ru&clientid=2&authkey=authkey&os=linux” -O $TF && sh $TF; rm $TF

urbackupclientctl set-settings -k internet_mode_enabled -v true -k internet_server -v server_ip -k internet_server_port -v 55415 -k computername -v “client computer name” -k internet_authkey -v authkey

then install dattobd driver, then add root directory by

urbackupclientctl add-backupdir -d /

restart service:

service urbackupclientbackend restart

list of directories:

root@client# urbackupclientctl list

/ root follow_symlinks,symlinks_optional,share_hashes

but, on server side client was marked as:

No paths to backup configured

what am I doing wrong?



Please, help.

I am assuming you are seeing “No paths to backup configured” on the Status page of the web interface.
That message is in reference to last time it tried to run.
Did you check the settings for the client on the web interface to see if the path is defined there?
If not, you can set it there. Sometimes it takes a bit to sync up.

Try starting a backup again.

1 Like

Yes, I see “No paths to backup configured” on the status page on server. I tried check box “Separate settings for this client” for that linux client and setup parameters “Included files (with wildcards)” and “Default directories to backup”, then restart server and client services, waited a some hours but nothing. The same error

Not sure what you are putting in the include/exclude lines, but I do this:
separated by semicolons

Exclude: /dev/;/run/;/sys/;/proc/*; etc, etc, etc
Default: /

1 Like

Yes! Yes! Yes! It works! Thanks for the advice! Remove include parameter, and setup exclude separately for client solved the problem.