Mac OS 10.13 HighSierra (APFS?) client fails - Sierra works


#21

it works like this:

 tmutil deletelocalsnapshots <snapshot_date>

bash-3.2# tmutil localsnapshot
Created local snapshot with date: 2017-12-14-172436
bash-3.2# tmutil listlocalsnapshots /
com.apple.TimeMachine.2017-12-14-170118
com.apple.TimeMachine.2017-12-14-172436
bash-3.2# tmutil deletelocalsnapshots 2017-12-14-172436
Deleted local snapshot ‘2017-12-14-172436’


#22

Great! Shouldn’t be much of a problem to put together two scripts with this I guess.


#23

Well, have an iMac with High Sierra now for testing, hoping to find some time next week.

Dunno how to mount a snapshot, yet - or, how vs. where urbackup needs it?


#24

It’s probably mounted already. We just need to find the path where it is mounted usually.


#25

There seems at least some good documentation now:

May be the FDA problems on Mojave 10.14 could be worked around by using the local, hourly Time Machine snapshots for UrBackup?


#26

That’s a documentation of the file system itself. Not about the utils to manage it. (I don’t want to write I file system driver to create a snapshot :wink: ).

Still no dice for tmutil https://developer.apple.com/search/?q=tmutil https://developer.apple.com/library/archive/documentation/Darwin/Reference/ManPages/man8/tmutil.8.html