Is the virtual client really added?

Hello to you all,

According to the documentation, adding a virtual client to backup a large database with wal_archive is done with the following command:

urbackupclientctl set-settings -v virtual_clients -k wal

But how can I check that this instruction is actually in the settings.cfg config file?
I thought that earlier versions of the client contained a wal=virtual_clients line, but this is no longer the case.

Should the next command return such a line?

grep "wal=virtual_clients" /usr/local/var/urbackup/data/settings.cfg

Thanks in advance,


I’m sorry I cant give you a direct anwser, but I got curious and checked the settings.cfg on my client (2.5.23 linux client) and all I can find about virtual clients is:

Where did you find that information you are referring to?
I checked the documentation but can not find anything about that.
Please send a link and maybe I can help analyze what is going on.

Thank you for your message. The only information I have is the official urbackup documentation: PosgreSQL: How to backup and restore PostgreSQL

Add a virtual client with :

urbackupclientctl set-settings -v virtual_clients -k wal

How can I check that the command has been taken into account by consulting the settings.cfg file?

wal=virtual_clients is something I noticed with client 2.4.11 and kept in my personal notes…

I’m using client version v2.5.24.0 and wal_archive backup of a PostgreSQL database doesn’t work for me.

Where the actual configuration is saved, I have no clue, sorry.

Is the client showing up on the server side so you know that it’s client side and not server side the problem lies?
Reason I ask, you never state you have problems running backups, you ask where the settings are stored.

So is the client working and you only need info on the config file or does your client not connect to the server?

I’ve been using urbackup for several years and i currently back up more than a hundred machines, without any problems, with the exception of a VM that contains several large databases that i want to back up with wal_archive… But as explained in wal archive postgresql database fails, this backup worked fine up to version 2.4.11 of the client but with higher versions, the backup fails with the following message:

Error saving metadata. Could not open output file at ".../.hashes/urbackup_backup_scripts/postgresbase/*.dir_metadata"

Suppose I want to disable wal_archive backup of this VM, I don’t know how to go about it, because it’s not documented properly.

As for you, searching for virtual_clients in the settings.cfg file does not give the expected result.

How do I remove the virtual client that was added with the urbackupclientctl command set-settings -v virtual_clients -k wal command?

The only solution seems to be to delete the settings.cfg file and start all over again: delete and reinstall the client.

Sorry, cant help.

But you are versions behind, latest is 2.5.31 on server and 2.5.24 on client.
Updating to latest might solve it.

Now I see what you are saying, it has not worked since 2.4.11.
Debug logs might help, change debug level and go from there maybe?