IP of Internet server backup change auto

i have a local and an internet urbackup server. 2.1.9 version.
internet backup is on a vpn. exemple :
local urbackup server :
internet urbackup server :

i had generated the client files from internet backup (it’s have the ip in setting).
i had installed it on client, windows 2012r2.
ip of internet backup is ok,

But after some minutes, this ip change to

i had tested :

  • stop urbackup service on client, about 1 hour
  • modify IP in settings.cfg file
  • restart urbackup service.

Gui show correct ip,
but after some minutes, it’s

so, how can i correct it ?
thank you


I think it s solved in the client beta version. Please check the changelog to be sure.
The bug is that the client is supposed to manage multiple internet servers, but actually it save only the first one it connects to.
Else maybe disable internet mode on your local server

Hi Orogor,
i had updated the client with 2.2.2 beta version.
Same result.

I need internet mode, so,
I had just made the change again, with and
change “settings.cfg” file rights of system account to Deny :slight_smile:
will see and come back.

Change write access to deny for system account user do the trick :slight_smile:
Don’t forget to put read access, or it doesn’t work.

It’s work, waiting for a correction if possible :slight_smile: