I was able to mount a .vhdz backup file on my Ubuntu server...but how do i unmount it?


I’ve been using urbackup for a few years. Today was the first time i’ve needed to look at a backup so i searched how to mount a .vhdz file on my Ubuntu server. I found a forums post that suggested the following (which i ran):

sudo urbackupsrv mount-vhd --file FILENAME --mountpoint /home/cj

This worked great. I was able to look at my backup. However, i have two issues.

  1. i assumed This would mount my .vhdz IN this directory. It seems that it mounted OVER my files in that directory? I had my documents/pictures/videos here and I can no longer see them…
  2. How do i Unmount this .vhdz (HOPEFULLY in such a way that I have access to my other files).

Did i royally mess up? Or is there a simple solution to unmount this .vhdz backup? I’ve read throught the FAQ, and the urbackup manual and can’t seem to find a solution. Thank you very much for any assistance.

Pretty new to all of this but found my solution (if anyone else runs across this).

sudo umount /home/cj

This removed all the files from my .vhdz backup and my prior files all returned. Also, an important note, its not unmount but umount.