Help Identifying Bottlenecks (Slow Backup speeds)


#1

Just installed urBackup on my fileserver and desktop and another client, and everything seems to be working smoothly. However, I noticed that my desktop seems to be capped to about 170Mbps (20ish MB/sec) despite having a gigabit link to the server. Both the client and server are capable of read and write speeds north of 200MB/sec, and both have beefy CPUs that are have single digit utilization. The server database is on an NVME ssd (not the backup disk). Any suggestions as to other bottlenecks/ tweaks that I could look at? Ideally I would be able to get 900+Mbps to the server. Thanks.


#2

Try enabling:
Settings | Advanced | Run backups with background priority on the clients:


#3

@silversword The setting was actually already enabled (weird, I thought i had disabled it already) and disabling it had no effect.


#4

Try disabling and re-running…sorry, can’t remember which one was recommended. I haven’t had the problem for a while on the server has been operational here for a while. Used to have the problem. While you’re there also make sure the server bandwidth usage is blank and not specified (of course that would slow the backup down)


#5

@silversword Tried re reunning after the disable before I posted my last comment, still no change.

All bandwidth limits are blank.

Edit: Also do I need to tag you in rach reply? On other forums I would usually just quote someone but that doesnt seem to be a feature here.


#6

No, when I reply, I auto-watch the thread so there will be a notification associated with my account.

Highlight the text in the message before clicking reply button and it will add as a quote in new message. Do it again part way thru typing and there’s a hover “quote” button that will add another quote block in your reply dialog. I believe going thru the welcome wizard (menu under your name circle top right) will teach you this and other things.


#7

Hi

On windows peoples had problems with :
congestion control : netsh interface tcp set global ecncapability=disabled

And tcp offloading (checkbox in network card properties)