Free space management not working in 2.4.11?

2.4.11 has been working fine for a while, but last Friday shut down because the dedicated drive for backups (2T drive, 1.8T usable by urbackup) filled up. Nothing in the logs other than a warning, then error, about not enough free space. I have the Global soft filesystem quota set to 85%, but apparently that’s not enough to keep things from filling up. Is there another option I should be setting?

After a reboot, the system ‘cleaned’ up enough to bring it down to 96% full, but that doesn’t seem like its going to be enough.


Hi! Same situation that on servers before.
I use this maintenance scenario:

  1. Stop urbackup server service.
  2. Use this commands from cli:
    sudo urbackupsrv repair-database
    sudo urbackupsrv defrag-database
    sudo urbackupsrv remove-unknown
    sudo urbackupsrv cleanup --amount 85
    last command option use with quota that you configured.
    Some commands execution can take a while…
    Also restart server, but if you use Linux check that system moves partition to read-only mode due fstab settings.

Please don’t use those commands without knowing what they do and having an indication that they would fix the problem.

1 Like

The ‘urbackupsrv cleanup’, from the man page description, seemed to be ‘safe’ enough and did free up enough room for things to start working again.

I’d agree, I would think I’d not need to run command line tools to keep the server running. Am I mis-interpreting what the “Global soft filesystem quota” setting is for, and is there some other/better way to make sure the server doesn’t fill up the drive.