Fail to backup of windev server - HFSQL bdd


#1

Hello,
I have a windows 2012r2 server with WinDev program.
Database is HFSQL.
Yes, i like it too :slight_smile:

I made files backup and images backup.
Backup success, restoring too but… there is “nothing” :
OS Windows OK but there no data. Nothing.
Files backup too : no files of database, no ZIP files generated by internal backup program of WinDev.

Certainly more complicated to backup :slight_smile:


#2

Check debug log to verify why files aren’t being backed up. Check exclusion filters. What’s the file extension of HFSQL files, bdd?


#3

Hello Silversword,
sorry for my late response I had not seen that there was an answer about this topic.

OS windows 2012 is on C: drive
windev bdd on D: drive

  • Files filter exclusion :
    C:\Users\ADMINI~1.TPR\AppData\Local\Temp\6\*;:\Pagefile.sys;:\System Volume Information\MountPointManagerRemoteDatabase;C:\ProgramData\Microsoft\RAC\:;:\System Volume Information\*{3808876B-C176-4e48-B7AE-04046E6CC752};:\System Volume Information\Heat\*.*;C:\Windows\softwaredistribution\*.*;C:\Windows\Minidump\*;:\hiberfil.sys;C:\Windows\system32\MSDtc\MSDTC.LOG;C:\Users\administrateur.TPR\index.dat;:\System Volume Information\:.{7cc467ef-6865-4831-853f-2a4817fd1bca}ALT;C:\Windows\system32\LogFiles\WMI\RtBackup\:.:;:\System Volume Information\:.{7cc467ef-6865-4831-853f-2a4817fd1bca}DB;C:\Windows\netlogon.chg;C:\ProgramData\Microsoft\Windows\WER\*;C:\ProgramData\Microsoft\Network\Downloader\:;C:\Windows\System32\Bits.log;C:\Windows\System32\Bits.bak;D:\ADCI\*.*;C:\Users\adciuser\index.dat;C:\Users\Administrateur\index.dat;C:\Users\:\AppData\Local\Temp;C:\Users\:\AppData\Local\Microsoft\Windows\Temporary Internet Files;C:\Users\:\AppData\Local\Google\Chrome\User Data\Default\Cache;C:\Users\:\AppData\Local\Google\Chrome\User Data\Default\Media Cache;C:\Users\:\AppData\Local\Microsoft\Windows\Explorer\thumbcache*;C:\Users\:\AppData\Local\Mozilla\Firefox\Profiles\:\cache2;C:\Users\:\AppData\Local\Mozilla\Firefox\Profiles\:\cache;C:\Windows\Temp;:\$Recycle.Bin;:\System Volume Information;C:\Windows.old;C:\$Windows.~BT;C:\ProgramData\Microsoft\Windows Defender\Scans\mpcache-*

  • Files extension of database :
    .fic, .ndx, .mmo

debug log file on client :
begin of file :

2018-07-12 08:53:58: WARNING: Info not found at 'd:' - reindexing
2018-07-12 08:55:59: ERROR: Error while enumerating user groups: 2453
2018-07-12 08:55:59: ERROR: Error while enumerating DC user groups: 2221
2018-07-12 08:55:59: ERROR: Error while enumerating DC user groups: 234
2018-07-12 08:55:59: ERROR: Error while enumerating DC user groups: 234
2018-07-12 08:56:08: WARNING: Info not found at 'c:' - reindexing
2018-07-12 09:08:43: ERROR: Not found

and there is very much line like this , at same time / date :

2018-07-16 04:18:47: WARNING: Parent directory not found in MFT. Was probably deleted.
2018-07-16 04:18:47: WARNING: Parent of file with FRN 9570149208335931 (Name "x86_microsoft-windows-ucrt_31bf3856ad364e35_6.3.9600.19023_none_40a08f0234ea1337_ucrtbase.dll_a00b9625") with FRN 6453658266021946499 not found. Searching via MFT as fallback. 

2018-07-16 04:18:47: WARNING: Parent directory not found in MFT. Was probably deleted.
2018-07-16 04:18:47: WARNING: Parent of file with FRN 1125899906983825 (Name "x86_microsoft-windows-com-base.resources_31bf3856ad364e35_6.3.9600.19038_fr-fr_efdc1a434c0f6a90_combase.dll.mui_6db10b33") with FRN 6453376791045235843 not found. Searching via MFT as fallback.

Searching via MFT as fallback.
2018-07-16 04:18:47: WARNING: Parent directory not found in MFT. Was probably deleted.
2018-07-16 04:18:47: WARNING: Parent of file with FRN 1407374883694478 (Name "wow64_microsoft-windows-win32k_31bf3856ad364e35_6.3.9600.19064_none_b41bd9e5a2ceafbb_wow64_win32k.ptxml_dde46f2d") with FRN 6452813841091814531 not found. Searching via MFT as fallback.


2018-07-12 17:07:24: WARNING: Parent of file with FRN 18577348462949981 (Name "DevisBTP_XP.wdp.ini") with FRN 19421773393081947 not found. Searching via MFT as fallback.

#4

“put your hands up in the air, put your hands up, in the air” :slight_smile:


#5

That looks like a NTFS file system error. You run chkdsk /f (or /r to do a surface scan) to make sure the file system is good?


#6

ok.
No, i haven’t do that.
The server isn’t old and in production.
I can do a robocopy or rsync of the files without problem.
I will find a moment and do a chkdsk with a backup before (it’s a VM).


#7

Electronic devices can be dead brand new in the box, or still keep going strong a decade after install. There’s no telling what you’re going to get.

If it’s a VM, then you need to do the Hypervisor’s disk and check for errors as well as file structure inside the disk image used for the VM.

NTFS is built to be redundant, with multiple MFT’s and other protections. You might still be able to get the files copied but have underlying errors.

Before troubleshooting anything else, you have to know that all the components in the OSI model of the device is stable before trying to fix the last error in the chain.

Hardware first:

  1. RAM
  2. Disk (SMART)
  3. Disk: File system

Then Software

  1. OS installation (Event log)
  2. Program installation and it’s error messages.

Since you’re running a VM you’ve got 2 sets of those layers to check.