Error creating temporary file

Dear all, I have a question about an error when starting a backup of files (completed backup)
I have a urbackup server instaled in a linux machine.
I have a client in a windows 7 machine.

Frem the webinterface of the server I see the windows machine and everything looks fine.
Then when I start a backup (either from the server or from the client) I obtain the following logs:
In the Server:

Error creating temporary file in ::doFullBackup
Backup failed[/quote]

In the Client:

[quote=""]Starting full file backup…
Removing reference because restart own was specified and only own tokens are present
Indexing of “misc” done. 2 filesystem lookups 0 db lookups and 0 db updates
Error opening temporary file. Retrying…
Error opening temporary file. Retrying…
Error creating temporary file in ::doFullBackup
Time taken for backing up client Sory-PC: 1m 31s
Backup failed[/quote]

Any ides of whats wrong in my configuration??
Any help would be realy apreciated,

Thanks in advance

This error occurs if the UrBackup server fails to create a temporary file in the “urbackup_tmp_files” subfolder of your backup folder. So please make sure that UrBackup can create files there.

If you enable “Temporary files as file backup buffer” in the advanced files it will use the system wide temporary folder instead.

Thankyou for the answer!!

It seems that using the system folder to create temp files urbackup has no permisions.
Now I have unchecked “Temporary files as file backup buffer” so a temp folder is created where backups are saved and it works fine!

Thank you again! ;)


I am experiencing the same problem.
It started after accidenally chowning the folder for the backups to another user.
I got the message that the backup folder and the folder for temporary files are not accessible.
After correcting the ownership (chroot -R urbackup:urbackup /path/to/backups), the one error message disappeared.
But the message regarding the access of the temp folder did not. What could be the reason?
The option to use the system folder is unchecked.