Clients are not auto updating


#1

Hi guys for some reason my clients are not updating their software. They received the updated version and I can see the urbackupupdate.exe in the program files. If I right click the tray icon and press info it tells me an update is available and clicking it will run the wizard that upgrades the client software without any error. I have over 50 clients so I don’t want to go to each one and run the wizard. I have the following:

Download client from update server: enabled
Autoupdate clients: enabled
Perform autoupdates silently: enabled

I tried restarting the client and the server. I also did the 5 minutes offline duration of the client. All my attempts failed! Does anyone know what am missing?


#2

I attached screenshots of my back end (settings: General, Permission, Client) and the info at the client where it shows the software was pushed but was not installed.

40 AM

42 AM

41 AM


#3

I am having the same problem described here. I have been running 2.2.11 for quite a while and have never had the auto-update client settings turned on, so have never tried a client upgrade. I upgraded the urbackup server from 2.2.11 to 2.3.7 successfully, and turned on the 3 settings: General settings, autoupdate client and download client from update server. The clients are in a group, and on that group I also have checkmarked Client, Perform autoupdates silently. Have tried having the server (Debian) and clients shutdown/off for at least a day and then powered on, and the clients (windows) still do not update, but in the Infos tab, show the button that an update is available.

Any suggestions on how to troubleshoot and get the clients updating? Thank you