Client on Centos 5

is there some option to install client on Centos 5?

Yes, I would like to know as well if there is an option for centos 5

It’s painful and I’ve tried everything I can think of and it just won’t work. If you try
./configure --enable-headless

You get farther, but you end up needing some extra libraries. But you can get the cryptopp and cryptopp-devel from

After that “./configure --enable-headless” works but then “make” fails. I haven’t been able to get past those make errors.

My take from this is your screwed if you need to backup anything old.

If you want to you could paste the compile errors here. Perhaps they are easily fixable.


I get the following error with both the 1.4.10 version and the 1.4.8 version.

make[2]: Entering directory `/root/urbackup-client-1.4.10’
g++ -DHAVE_CONFIG_H -I. -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security -D_FORTIFY_SOURCE=2 -pthread -DLINUX -g -O2 -MT AcceptThread.o -MD -MP -MF .deps/AcceptThread.Tpo -c -o AcceptThread.o AcceptThread.cpp
cc1plus: error: unrecognized command line option “-Werror=format-security”

I’ve tried searching what the “format-security” option does but I just don’t know enough about build options to play around with the Makefile. Thanks for taking the time to look. If this works I’ll try the same thing on some older Ubuntu boxes as well.

Could you try with ./configure --enable-headless --disable-fortify ?

That did the trick! Thanks for the suggestion.