Cbt new install on windows 7 pro not working

I’ve just installed CBT on a windows 7 client. However, the CBT driver is not working. I get the following error in windows system logs:

Event 7000 Service Control Manager
The urbackupcbt service failed to start due to the following error:
The specified procedure could not be found.

Details Tab:

  • System
  • Provider

[ Name] Service Control Manager
[ Guid] {555908d1-a6d7-4695-8e1e-26931d2012f4}
[ EventSourceName] Service Control Manager

  • EventID 7000

[ Qualifiers] 49152

Version 0

Level 2

Task 0

Opcode 0

Keywords 0x8080000000000000

  • TimeCreated

[ SystemTime] 2017-04-22T03:11:31.884524800Z

EventRecordID 236893


  • Execution

[ ProcessID] 460
[ ThreadID] 616

Channel System

Computer shipping


  • EventData

param1 urbackupcbt
param2 %%127

I installed the CBT as a local administrator by right clicking and chose “run as administrator…” I’m not sure what to do next, it seems like something is wrong in the installer


Since it is a new install, maybe it is missing the SHA2 windows update?

Thanks uroni,

I did not communicate the issue well; It’s a new install of CBT over the regular urbackup install. Windows has been running on this computer for a long time. It’s fully updated and patched. I did however try to download and install KB3033929 (the SHA256 update), but windows politely informed me that it is already installed.

Any other suggestions / idea?

Is this a 32bit or 64bit Windows? Could you send me “C:\Windows\System32\drivers\urbackupcbt.sys” ?

It’s a 32-bit install. I’ve attached the file you asked for.

Does “C:\Windows\System32\drivers\WdfLdr.sys” exist?

Yes, WdfLdr.sys does exist. It’s dated 2012-07-25.

Thanks for reporting this issue and the help! Should be fixed with 2.1.18-cbt now.

So… I upgraded to 2.1.18-cbt, then rebooted (twice). I see am on the new version, but the backups are taking the same amount of time. So I checked the client but it reports “Volumes without change block tracking: C:”. So I found this thread CBT disabled after live disk resizing and tried the suggestion from TomTomGo.

However, it did not work, here is the error:

C:\Program Files\UrBackup>urbctctl.exe install C: n-c
Driver installed successfully
Unlocking bitmap file failed. Err: 1
Cannot create bitmap file. Err: 32
Unable to install bitmap file

As always, I am grateful for the software and your help!

Have you try to remove the driver first, i.e urbctctl.exe uninstall C: ?
The sequence which have worked for me (as i can remember) was :

urbctctl.exe uninstall C:
Reboot the client
Check status with urbctctl.exe status C:
If problem persists i you should have try :
urbctctl.exe reset C: and then urbctctl.exe uninstall C: and reboot again

And finally, when urbctctl.exe status C: returns no errors :

urbctctl.exe install C: n-c and reboot

Thanks for the help TomTom!

I ran CMD.exe from an administrator account, and I ran CMD.exe by right-clicking and choosing “run as administrator…” Here is what I get when I follow the above steps:

C:\Users\aetco>cd “c:\Program Files\UrBackup”

c:\Program Files\UrBackup>urbctctl.exe status C:
> Change block tracking disabled on C:

c:\Program Files\UrBackup>urbctctl.exe reset C:
> Resetting change block tracking on volume C:… failed
> Reseting change block tracking on volume C: failed. Error code: 1

c:\Program Files\UrBackup>urbctctl.exe uninstall C:
> One or more devices could not be restarted. The machine must be restarted
> in order for settings to take effect

*) I rebooted here

C:\Users\aetco>cd “c:\Program Files\UrBackup”

c:\Program Files\UrBackup>urbctctl.exe install C: n-c
> Driver installed successfully
> Unlocking bitmap file failed. Err: 1
> Cannot create bitmap file. Err: 32
> Unable to install bitmap file

Do you have a look at this thread ?

Woo Hoo! That did the trick. Thanks again TomTom!

It should have worked without running it on the command line with a restart. When it complains about not being able to create the bitmap it usually already set everything up and is waiting for a restart. Tell me if you experience something else. Thanks!