Backup failure - vss?


I’ve got problem with some clients. I checked if there are any errors with Volume Shadow Copy in the event viewer, but VSS seems to work fine (at least theoreticly). Those clients usually do the backup, but sometimes they have error like in the logs below:

2015-01-23 18:15:57(error): Cannot access directory to backup: “\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy[…]”
2015-01-23 18:15:57(error): Constructing of filelist of “CLIENT_NAME” failed: error - index error
2015-01-23 18:15:58(error): Backup had errors. Deleting partial backup.

If anyone could help me out with this one, I’d be gratefull.


I have exactly the same error from 1.4.7 version

When I get this error it is because the shadow copy is deleted during indexing (because it runs out of shadow storage). But in this case there would be a VSS event in the event viewer. Are you sure there isn’t one?

A client-side log would be helpfull I guess (C:\Program files\UrBackup\debug.log).


I tried to manualy create the shadow copy just to be sure there is no problem with vss itself. Later on I checked how much storage space this shadow copy takes. Used space by this copy is 862 MB and Maxium Shadow Copy Storage Space is 11GB, so I think that exceeding the storage is not the case in my scenario. I will post logs in a while. Thanks in advance.

I make try this week and say to you result of my investigation

I gave jollyjokester this version with more debug log info:

Still no luck, I will send you logs from this host today. I skimmed through them but not much more info was provided. Well, it’s odd because we had version 4.6 and it was working fine for some time and then this issue showed up.